Adaptadores FCoE no detectados por ESXI 6.5

Estos días he detectado un pequeño problema con los adaptadores FCoE que te puede traer de cabeza unas horitas. Resulta al instalar vmware esxi 6.5 en unas máquinas nuevas, unos blades HP Proliant BL460c Gen9 con adaptador HP FlexFabric 10gb 536FLB ,  el equipo no detecta los adaptadores de fibra, según parece también pasa con otros fabricantes.

Lo primero que se ha hecho es comprobar la matriz de compatibilidad con vmware desde aqui

Tambien se ha actualizado el firmware a la ultima versión mediante el SPP de HP, seguimos con identico resultado.

Al final este problema tiene una solución bastante sencilla como se trata de la auto detección de FCoE en el arranque. Con  esxcli vamos a poder configurarlo.

Lo primero es ver nuestros adaptadores FCoE, nos saldrá seguramente vacío

esxcli fcoe adapter list

Listamos los adaptadores susceptibles de ser FCoE.

esxcli fcoe nic list

Activar el adaptador, indicando el nombre del adaptador necesario, por ejemplo vmnic2 o vmnic3.

esxcli fcoe nic enable -n vmnicX

Activar el modo de auto descubrimiento en el adaptador, indicar el nombre del adaptador como en el paso anterior.

esxcli fcoe nic discover -n vmnicX

Volver a comprobar el listado de adaptadores FCoE.

esxcli fcoe adapter list

Una vez realizado esto en el host problemático ya se pueden ver los adaptadores en el cliente en el cliente web.

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.