Skip to content
Inicio » Actualizando a vmware 6.5: problemas con un VIB

Actualizando a vmware 6.5: problemas con un VIB

logo vmware

Hoy he decidido actualizar mi vmware esxi de la versión 6.0 a 6.5. Aunque ya hice una entrada de como realizar esta actualización. Ha surgido un problemilla en mi sistema y en mi caso, y parece que no es tan raro, no me permitía realizar este cambio de versión tan facilmente debido a un problemilla con un VIB

En mi caso la información proporcionada por el sistema al intentar actualizar es:

[root@]  esxcli software vib install -d /vmfs/volumes/[DATASTORE]/VMware-ESXi-6.5.0-Update1-6765664-HPE-650.U1.9.6.5.1-Nov2017-depot.zip
 [DependencyError]
 VIB HUAWEI_bootbank_hio_2.0.0.42-1OEM.550.0.0.1331820 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.
 VIB HUAWEI_bootbank_hio_2.0.0.42-1OEM.550.0.0.1331820 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.
 Please refer to the log file for more details.

Tenemos un problema con el VIB HUAWEI_bootbank_hio. Para solucionarlo fácilmente lo vamos a eliminar. Primero sacamos un listado de los VIB de HUAWEI con el siguiente comando:

[root@] esxcli software vib list | grep HUAWEI
hio                            2.0.0.42-1OEM.550.0.0.1331820          HUAWEI               VMwareCertified   2016-05-27

Lo eliminamos con un simple remove.

[root@] esxcli software vib remove -n hio
Removal Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed:
   VIBs Removed: HUAWEI_bootbank_hio_2.0.0.42-1OEM.550.0.0.1331820
   VIBs Skipped:

Ahora ya podemos actualizar el equipo a esxi 6.5 esta vez sin problemas. Para ello utilizaremos el comando:

[root@]  esxcli software vib install -d /vmfs/volumes/[DATASTORE]/VMware-ESXi-6.5.0-Update1-6765664-HPE-650.U1.9.6.5.1-Nov2017-depot.zip
Installation Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true

Reiniciamos el equipo, en mi caso con las maquinas virtuales apagadas ya que es el único host fisico y ya tenemos disponible nuestra nueva versión.

Vmware esxi version 6.5 U1

Tambien esta disponible el articulo de como realizar la actualizacion de esxi de 6.0 a 6.5

1 thought on “Actualizando a vmware 6.5: problemas con un VIB”

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.